PHP is among the most commonly used open-source server-side programming languages. It’s pretty popular as it is free software, which you can use to build interactive websites such as community portals, e-commerce portals or online learning sites as opposed to static HTML-based websites. A PHP module must be present on the server where a PHP-driven website is hosted so that its code can be interpreted. As there aren’t any license taxes for this type of module and the language itself offers endless possibilities for the applications that you build, there are 100s of millions of PHP-powered sites. What is more, there’re a myriad of open-source PHP scripts, which you can use for your websites without needing to possess any programming abilities. Since there’re a few PHP versions, you should confirm whether the very same version that you used whilst building your site is present on the web server too.
PHP 4 and PHP 5 Support in Hosting
In case you buy a hosting package from us, you’ll never need to ask yourself whether your websites are compatible with the hosting platform, since we offer different PHP versions for your convenience. The Hepsia hosting Control Panel will allow you to pick PHP 5.5, 5.4, 5.3, 5.2 or 4 with only one single click of the mouse and in case you need to change the version, the update will take effect straight away. Thus, many years of work on sites built with an older version will not be in vain. Our web hosting platform will even allow you to use a different PHP version for each domain name hosted in your account, which suggests that you can run newer and older scripts simultaneously. Most web hosting companies on the market support one, sometimes two PHP versions. In stark contrast to them, we are strongly convinced that you should be the one to pick the version that will be used by your own websites.
PHP 4 and PHP 5 Support in Semi-dedicated Servers
It’s our unfaltering belief that years spent setting up a website should not be in vain, which implies that in case you buy a semi-dedicated server from our company, you will be able to use any script, new or old. In contrast to many companies, we support several different PHP versions on our innovative cloud hosting platform – 5.5, 5.4, 5.3, 5.2 and 4. Not only will you be able to enable the version that you need via your Hepsia hosting Control Panel, but you will also have the possibility to pick a different PHP version for each website. This can be accomplished simply by placing an .htaccess file inside the given site’s root folder. You can change the version either for a single website or for the whole account and the change will take effect in just a couple of minutes. With our hosting services, you can rest assured that you will never bump into any site compatibility complications.